Page 1 of 1

No 802.11 packet capture

Posted: Thu Apr 26, 2012 12:27 pm
by free06
I installed Omnipeek 6.6.1 demo, and install ralink_usb2870 driver for my D-Link DWA-140 N USB adapter.

Omnipeek did captures packets on my wireless adapter, but they are mostly Layer 3-7 packets (TCP, UDP, HTTP, ARP...). There are no wireless information captured at all.

Is there any extra step that I need to set up to get the wireless analysis?

Thank you.

RE: No 802.11 packet capture

Posted: Thu Apr 26, 2012 3:27 pm
by DJWP
The DWA-140 is not a supported adapter, however some of the revisions do use the Ralink 2870 chipset. Others, use the RT3072, however. Which revision do you have, B1, B2, B3?

It sounds as if you are in fact getting data packets, are you saying that you are not receiving management frames? If you have maintenance on your copy of OmniPeek, we would suggest contacting support for detailed troubleshooting of this issue:

http://www.wildpackets.com/support/contact

RE: RE: No 802.11 packet capture

Posted: Fri Apr 27, 2012 12:07 am
by free06
Thank you for the response. My DWA-140's revision is B1. Should I try RT3072 instead of RT2870?

Yes - my dashboard does not have the "Wireless" section, and all packets are not 801.11 related.

RE: No 802.11 packet capture

Posted: Fri Apr 27, 2012 12:09 am
by free06
I downloaded the driver directly from Ralink website, which is supposed to support RT2870 and RT307X. Still I got the same problem...

RE: RE: No 802.11 packet capture

Posted: Fri Apr 27, 2012 7:53 am
by DJWP
You will need to use a supported adapter and driver:

http://www.wildpackets.com/support/downloads/drivers