Page 1 of 1

Plugin incompatible with OP v6.8.2

Posted: Tue Oct 16, 2012 12:47 pm
by rjt387
Hi,

We have some plugins developed (using VS 2008) for OmniPeek that were compatible with OP versions 5.1 to 6.6. We upgraded our OP to latest 6.8.2, and the plugins do not seem to work anymore.

I rebuilt the plugins using MS VS 2010, but it did not work. Please help.

Thanks in advance.

RE: Plugin incompatible with OP v6.8.2

Posted: Tue Oct 16, 2012 3:30 pm
by rjt387
I just found out that the analysis module was built using Peek Analysis Module Wizard for API Version 11. Does the latest OP v6.8.2 not support plugins developed using API v11? Is there a way to re-build the module using API v12?

RE: RE: Plugin incompatible with OP v6.8.2

Posted: Tue Oct 16, 2012 3:46 pm
by Spacepacket
Hi rjt387,

Plug-ins using API v11 will work in OP v6.8.2. Step through the ::OnLoad() function and see if it is returning an error.

-spacepacket

RE: RE: RE: Plugin incompatible with OP v6.8.2

Posted: Wed Oct 17, 2012 4:36 pm
by rjt387
hi spacepacket,
I stepped through the onLoad() function, and seems like it is NOT returning an error, so problem lies somewhere else. Any ideas or suggestions?

thanks,
rjt387

RE: RE: RE: RE: Plugin incompatible with OP v6.8.2

Posted: Wed Oct 17, 2012 4:53 pm
by Spacepacket
I need more clues.

If you go to Tools->Options->Analysis Modules, is you plugin listed?

What does you plug-in normally do that it is not doing now?

-spacepacket

RE: RE: Plugin incompatible with OP v6.8.2

Posted: Wed Oct 17, 2012 5:02 pm
by rjt387
The plugin is listed and checked in Tools>options>analysis modules. It is a roaming analysis plugin, I see the plugin in the column on the left, but it is unable to show any packets/analysis in the window.
The plugin works on OP v6.6, but fails to do so on OPv6.8.2
thanks..