Drivers

Atheros USB 3.0 Driver for TP-LINK TL-WN821N

amsoares
Posts: 6
Joined: Wed May 07, 2008 11:06 am

Atheros USB 3.0 Driver for TP-LINK TL-WN821N

Postby amsoares » Tue May 29, 2012 3:08 am

I recently purchased one TL-LINK TL-WN821N usb dongle in order to try OmniPeek Demo. I have Windows 7 x64 and Windows detects this device as Atheros AR7015 Adapter. After that i tried to update the driver with the one provided with OmniPeek installation at C:\Program Files (x86)\WildPackets\OmniPeek Demo\Drivers\Atheros\Atheros_USB_3.0\x86_64\
This driver seems to support my adapted since i see it in the list but it doesn't work. My laptop becames unstable, i got several blue screens, and OmniPeek is not able to capture any traffic. I wonder if my device is really supported. Windows detects it as AR7015 so maybe this is an unsupported chipset. I tried to install the TP-LINK driver (http://www.tp-link.com/Resources/softwa ... Driver.zip) and the laptop is stable again but OmniPeek is not able to capture the traffic (WildPackets API=no). Do i have a problem related with the hardware version of my usb adapter ? There are V1, V2 and V3 and i have V3.

DJWP
Posts: 687
Joined: Tue Oct 30, 2007 11:42 am

RE: Atheros USB 3.0 Driver for TP-LINK TL-WN821N

Postby DJWP » Tue May 29, 2012 8:58 am

This is not a supported adapter at the present time, but you should make sure you are installing the 64 bit version in any case.

amsoares
Posts: 6
Joined: Wed May 07, 2008 11:06 am

RE: RE: Atheros USB 3.0 Driver for TP-LINK TL-WN821N

Postby amsoares » Tue May 29, 2012 9:40 am

Thanks DJWP. Yes, i'm installing the x64 version of the driver (file arusb_xpx.sys). I don't understand, the device i have is not supported at all of the hardware version of the device i have is not supported ? I'm asking this because the TP-LINK 821N appears in the arusb_xp.inf file:

ATHR.DeviceDesc.1002 = "TP-LINK TL-WN821N 11N Wireless Adapter"

DJWP
Posts: 687
Joined: Tue Oct 30, 2007 11:42 am

RE: RE: RE: Atheros USB 3.0 Driver for TP-LINK TL-WN821N

Postby DJWP » Tue May 29, 2012 4:48 pm

WildPackets has not tested that device with the Atheros USB driver. If the driver loads successfully, in the Adapter dialog of the Capture Options in OmniPeek, it will say WildPackets API=Yes.

If it does not, than the custom driver did not load.

amsoares
Posts: 6
Joined: Wed May 07, 2008 11:06 am

RE: RE: RE: RE: Atheros USB 3.0 Driver for TP-LINK TL-WN821N

Postby amsoares » Thu May 31, 2012 7:22 am

Under Windows 7, the WildPacketsAPI says Yes but the laptop is unstable and it doesn't capture any packets. The device does not appear in the "Safely Remove Hardware and Eject Media", the Virtual WiFi Miniport associated with this adapter doesn't appear, if i remove the usb stick i get a bluescreen... I tried under Windows XP x32 but it says that there is no driver for this hardware... Ok, i give up. What is the recommended usb adapter that works under Windows 7 x64 ? I saw some references to the D-LINK DWA160 but even with this one, it seems we can get an hardware revision that doesn't work. How can i be 100% safe that the usb adapter will work ?

DJWP
Posts: 687
Joined: Tue Oct 30, 2007 11:42 am

RE: RE: RE: RE: RE: Atheros USB 3.0 Driver for TP-LINK TL-WN

Postby DJWP » Thu May 31, 2012 8:41 am

Here is the list of supported adapters:

http://www.wildpackets.com/support/downloads/drivers


Return to “Drivers”

Who is online

Users browsing this forum: No registered users and 1 guest